summaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-23 12:23:11 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-01-25 22:21:28 -0500
commit1d41f7770182f4225dcb7ab197bf0a5b9cca603a (patch)
treead4820b47698730973eab96a9436500d9d778912 /gnu/packages/chemistry.scm
parent68dabe3c1c5a40e060d740b0365f066773297880 (diff)
downloadguix-patches-1d41f7770182f4225dcb7ab197bf0a5b9cca603a.tar
guix-patches-1d41f7770182f4225dcb7ab197bf0a5b9cca603a.tar.gz
gnu: Add avogadrolibs.
* gnu/packages/chemistry.scm (avogadrolibs): New variable.
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index e97648fa3b..e2a1ef57e1 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -44,6 +45,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages xml)
#:use-module (guix build-system cmake)
@@ -135,6 +137,48 @@ science, and related areas. It offers flexible high quality rendering and a
powerful plugin architecture.")
(license license:gpl2+)))
+(define-public avogadrolibs
+ (package
+ (name "avogadrolibs")
+ (version "1.93.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenChemistry/avogadrolibs")
+ (commit version)))
+ (sha256
+ (base32 "1xivga626n5acnmwmym8svl0pdri8hkp59czf04ri2zflnviyh39"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("eigen" ,eigen)
+ ("mmtf-cpp" ,mmtf-cpp)
+ ("msgpack" ,msgpack)
+ ("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)
+ ("pybind11" ,pybind11)))
+ (inputs
+ `(("glew" ,glew)
+ ("libarchive" ,libarchive)
+ ("libmsym" ,libmsym)
+ ("molequeue" ,molequeue)
+ ("python" ,python)
+ ("spglib" ,spglib)
+ ("qtbase" ,qtbase)))
+ (arguments
+ '(#:configure-flags (list "-DENABLE_TESTING=ON"
+ (string-append "-DSPGLIB_INCLUDE_DIR="
+ (assoc-ref %build-inputs "spglib")
+ "/include"))))
+ (home-page "https://www.openchemistry.org/projects/avogadro2/")
+ (synopsis "Libraries for chemistry, bioinformatics, and related areas")
+ (description
+ "Avogadro libraries provide 3D rendering, visualization, analysis and data
+processing useful in computational chemistry, molecular modeling,
+bioinformatics, materials science, and related areas.")
+ (license license:bsd-3)))
+
(define-public domainfinder
(package
(name "domainfinder")