summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-10 19:13:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-10 20:09:56 +0200
commitff0efc8f6c35606878ca009f3582f5257db2c9e3 (patch)
tree9f95603ff7947c404a17811f46ef83d2d30723e4 /gnu/packages/check.scm
parentef42bc3e56b159b36207303dd5b54b6c52574c40 (diff)
downloadguix-patches-ff0efc8f6c35606878ca009f3582f5257db2c9e3.tar
guix-patches-ff0efc8f6c35606878ca009f3582f5257db2c9e3.tar.gz
gnu: python-bleach: Update to 3.1.0.
* gnu/packages/check.scm (python-pytest-runner-2, python2-pytest-runner-2): New public variables. * gnu/packages/python-xyz.scm (python-bleach): Update to 3.1.0. [propagated-inputs]: Remove PYTHON-HTML5LIB-0.9. Add PYTHON-WEBENCODINGS. [native-inputs]: Remove PYTHON-NOSE. Add PYTHON-PYTEST and PYTHON-PYTEST-RUNNER-2.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index dab0bd39c3..c7d8615b0b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -816,6 +816,22 @@ supports coverage of subprocesses.")
(define-public python2-pytest-runner
(package-with-python2 python-pytest-runner))
+;; python-bleach 3.1.0 requires this ancient version of pytest-runner.
+;; Remove once no longer needed.
+(define-public python-pytest-runner-2
+ (package/inherit
+ python-pytest-runner
+ (version "2.12.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-runner" version))
+ (sha256
+ (base32
+ "11ivjj9hfphkv4yfb2g74av4yy86y8gcbf7gbif0p1hcdfnxg3w6"))))))
+
+(define-public python2-pytest-runner-2
+ (package-with-python2 python-pytest-runner-2))
+
(define-public python-pytest-mock
(package
(name "python-pytest-mock")