summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:33:09 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:37:26 +0000
commite486b2b674badc80627b11077b7df2ac1cab92d8 (patch)
tree5909547a69c4b185b878c8f0fe8152f1c01fef04 /gnu/packages/check.scm
parent0df1eb029efe5ebe3f02e36fa650cae4aaba89ec (diff)
parent88badc074a5dbebf80115918cf6c0009075154d2 (diff)
downloadguix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar
guix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c839f83c1d..c6c078b08f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2122,6 +2122,17 @@ seamlessly into your existing Python unit testing work flow.")
(license license:mpl2.0)
(properties `((python2-variant . ,(delay python2-hypothesis))))))
+(define-public python-hypothesis-6.23
+ (package
+ (inherit python-hypothesis)
+ (version "6.23.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hypothesis" version))
+ (sha256
+ (base32
+ "0lqhfrqsd81apchz93pdqfn85kx0p790w8hhd9qq85692rwja6xp"))))))
+
;; This is the last version of Hypothesis that supports Python 2.
(define-public python2-hypothesis
(let ((hypothesis (package-with-python2