summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-27 23:35:12 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-29 14:02:46 -0500
commitd4732deb4f885152e98b64a70806fbe5e4b44843 (patch)
tree0e48e581d83e08ef01ee1d4f16afddf0905198e9 /gnu/packages/check.scm
parentcbb03bd5211d93526ce9a08920eebaa48d0ad27b (diff)
downloadguix-patches-d4732deb4f885152e98b64a70806fbe5e4b44843.tar
guix-patches-d4732deb4f885152e98b64a70806fbe5e4b44843.tar.gz
gnu: Add python-pytest-6.
* gnu/packages/check.scm (python-pytest-6): New variable. (python-pytest-6-bootstrap): Likewise.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm52
1 files changed, 51 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index cf9b85d592..ccdef2a210 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,7 +82,8 @@
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
- #:use-module (guix build-system trivial))
+ #:use-module (guix build-system trivial)
+ #:use-module (srfi srfi-1))
(define-public pedansee
(package
@@ -931,6 +933,45 @@ and many external plugins.")
(license license:expat)
(properties `((python2-variant . ,(delay python2-pytest))))))
+(define-public python-pytest-6
+ (package
+ (inherit (strip-python2-variant python-pytest))
+ (version "6.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32
+ "0gl2sdm322vzmsh5k4f8kj9raiq2y7kdinnca4m45ifvii5fk9y0"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key (tests? #t) #:allow-other-keys)
+ (setenv "TERM" "dumb") ;attempt disabling markup tests
+ (if tests?
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; This test involve the /usr directory, and fails.
+ " not test_argcomplete"
+ ;; These test do not honor the isatty detection and
+ ;; fail.
+ " and not test_code_highlight"
+ " and not test_color_yes"))
+ (format #t "test suite not run~%"))
+ #t)))))
+ (propagated-inputs
+ (append (alist-delete "python-py"
+ (package-propagated-inputs python-pytest))
+ `(("python-py" ,python-py-next))))
+ (native-inputs
+ (append (alist-delete "python-pytest"
+ (package-native-inputs python-pytest))
+ `(("python-pytest" ,python-pytest-6-bootstrap)
+ ("python-toml" ,python-toml)
+ ("python-iniconfig" ,python-iniconfig))))))
+
;; Pytest 4.x are the last versions that support Python 2.
(define-public python2-pytest
(package
@@ -975,6 +1016,15 @@ and many external plugins.")
(arguments `(#:tests? #f))
(properties `((python2-variant . ,(delay python2-pytest-bootstrap))))))
+(define-public python-pytest-6-bootstrap
+ (package
+ (inherit (strip-python2-variant python-pytest-6))
+ (name "python-pytest-bootstrap")
+ (arguments `(#:tests? #f))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-toml" ,python-toml)))))
+
(define-public python2-pytest-bootstrap
(hidden-package
(package/inherit