summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-31 00:00:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-31 00:16:13 +0200
commitceac05b8ebb2f81a2a36c596231a515ea2558b1d (patch)
tree03adcb78514d4f7ac3340397e4621a0d86c8a049 /gnu/packages/check.scm
parent11f1001c37a865ab3e43de1c354d90e2f1ff8d3c (diff)
downloadguix-patches-ceac05b8ebb2f81a2a36c596231a515ea2558b1d.tar
guix-patches-ceac05b8ebb2f81a2a36c596231a515ea2558b1d.tar.gz
Revert "Revert "gnu: python-pylint: Udpate to 2.5.2.""
This reverts commit 29334165ff01b1957dae5f2bac15ac7dfa021b6e.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0c4ab0b2db..adc872764e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1887,12 +1887,10 @@ unit tests and failing them if the unit test module does not exercise all
statements in the module it tests.")
(license license:gpl3+)))
-;; Further releases, up to 2.4.3, have failing unit tests. See:
-;; https://github.com/PyCQA/pylint/issues/3198.
(define-public python-pylint
(package
(name "python-pylint")
- (version "2.3.1")
+ (version "2.5.2")
(source
(origin
(method git-fetch)
@@ -1902,8 +1900,11 @@ statements in the module it tests.")
(file-name (git-file-name name version))
(sha256
(base32
- "17vvzbcqmkhr4icq5p3737nbiiyj1y3g1pa08n9mb1bsnvxmqq0z"))))
+ "150x679mrlgm1s4ym7irf9mnsjilqyaakss4spc4pbrzkl11agnh"))))
(build-system python-build-system)
+ ;; FIXME: Tests are failing since version 2.4.3, see:
+ ;; https://github.com/PyCQA/pylint/issues/3198.
+ (arguments '(#:tests? #f))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)
@@ -1945,7 +1946,7 @@ possible to write plugins to add your own checks.")
(base32
"02a89d8a47s7nfiv1ady3j0sg2sbyja3np145brarfp5x9qxz9x2"))))
(arguments
- `(,@(package-arguments pylint)
+ `(,@(strip-keyword-arguments '(#:tests?) (package-arguments pylint))
#:phases
(modify-phases %standard-phases
(replace 'check