summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 09:33:10 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:01 +0100
commitc940b0e38e40d22c8fd13ca53cf31075349bcb29 (patch)
treee97aaa726e6ff32c3310a21790fc2590074de5c6 /gnu/packages/check.scm
parent22acec058803d98a0ed3bacc0734339cadae0d74 (diff)
downloadguix-patches-c940b0e38e40d22c8fd13ca53cf31075349bcb29.tar
guix-patches-c940b0e38e40d22c8fd13ca53cf31075349bcb29.tar.gz
gnu: behave: Update to 1.2.7.dev2.
* gnu/packages/check.scm (behave): Update to 1.2.7.dev2. [source]: Switch to GIT-FETCH. Remove patches. [arguments]: Remove #:test-target. Add #:phases. [propagated-inputs]: Add PYTHON-COLORAMA and PYTHON-CUCUMBER-TAG-EXPRESSIONS. * gnu/packages/patches/behave-skip-a-couple-of-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm32
1 files changed, 21 insertions, 11 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 2dbb95c899..fb5bcadf83 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2464,23 +2464,33 @@ backported from Python 2.7 for Python 2.4+.")
(define-public behave
(package
(name "behave")
- (version "1.2.6")
+ ;; The 1.2.6 release from 2018 has several problems with newer Python
+ ;; versions, so we package a recent snapshot.
+ (version "1.2.7.dev2")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "behave" version))
- (sha256
- (base32
- "11hsz365qglvpp1m1w16239c3kiw15lw7adha49lqaakm8kj6rmr"))
- (patches (search-patches
- "behave-skip-a-couple-of-tests.patch"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/behave/behave")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sv94wagi214h0l91zn8m04f78x5wn83vqxib81hnl1qahvx9hq7"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-c" "/dev/null" "-vv")))))))
(native-inputs
(list python-mock python-nose python-pathpy python-pyhamcrest
python-pytest))
(propagated-inputs
- (list python-parse python-parse-type))
- (arguments
- '(#:test-target "behave_test"))
+ (list python-colorama
+ python-cucumber-tag-expressions
+ python-parse
+ python-parse-type))
(home-page "https://github.com/behave/behave")
(synopsis "Python behavior-driven development")
(description