summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 23:06:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 23:08:37 -0400
commitc776b6ba8e3fc825d60cb292f18dcdf4eb38d95f (patch)
treea37010a2c7411a5080caff155ee1d03e32727510 /gnu/packages/check.scm
parente35e72425a030d97932c0a4b5beeb2a33f35a26e (diff)
downloadguix-patches-c776b6ba8e3fc825d60cb292f18dcdf4eb38d95f.tar
guix-patches-c776b6ba8e3fc825d60cb292f18dcdf4eb38d95f.tar.gz
gnu: Add python-pytest-assume.
* gnu/packages/check.scm (python-pytest-assume): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 287f633c58..9044d65252 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -35,7 +35,7 @@
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;;
;;; This file is part of GNU Guix.
@@ -1114,6 +1114,39 @@ and many external plugins.")
("python-py" ,python2-py)
("python-wcwidth" ,python2-wcwidth))))))
+(define-public python-pytest-assume
+ (package
+ (name "python-pytest-assume")
+ (version "2.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-assume" version))
+ (sha256
+ (base32 "0zilqsy9fcjr6l2f9qzfxpkp40h24csnjm5mifhpmzb0fr9r0glq"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/astraw38/pytest-assume")
+ (synopsis "Pytest plugin that allows multiple failures per test")
+
+ (description "This package provides a Pytest plugin that allows multiple
+failures per test. This is a fork from pytest-expect which includes the
+following improvements:
+@itemize
+@item showlocals support (the Pytest option)
+@item global usage support (a fixture is not required)
+@item output refinements and tweaks.
+@end itemize")
+ (license license:expat)))
+
(define-public python-pytest-cov
(package
(name "python-pytest-cov")