summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-24 08:03:26 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:11:15 +0200
commitc648fa4186ff8c9307b2379d75bba1955a9eec7f (patch)
treed967aa0bf145d40dce15ad6ddf79d4b0c76d37cc /gnu/packages/check.scm
parentd4cb5347d7c6d1b188597193ffa1c0ccbe2d88fa (diff)
downloadguix-patches-c648fa4186ff8c9307b2379d75bba1955a9eec7f.tar
guix-patches-c648fa4186ff8c9307b2379d75bba1955a9eec7f.tar.gz
gnu: Add pedansee.
* gnu/packages/check.scm (pedansee): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ae1ddfc801..a7db915597 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -76,12 +76,40 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial))
+(define-public pedansee
+ (package
+ (name "pedansee")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.flyn.org/projects/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0lsg791x6n95pxg6vif8qfc46nqcamhjq3g0dl5xqf6imy7n3acd"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("clang" ,clang)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
+ (inputs
+ `(("glib" ,glib)))
+ (synopsis "Code checker for C")
+ (description "Pedansee checks C source files for compliance with a particular
+programming style. The style is currently defined by the pedansee source code
+in the form of functions which walk each source file’s syntax tree. You can
+modify some aspects of this style through the use of regular expressions.")
+ (home-page "https://www.flyn.org/projects/pedansee/")
+ (license license:gpl3+)))
+
(define-public mutest
(package
(name "mutest")