summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-05-28 18:01:34 +0000
committerMarius Bakke <marius@gnu.org>2020-05-30 16:41:38 +0200
commitc2e19b6291cc4981e39d01aae85af0899614061d (patch)
treeed6a81e1f455793de7a6e437e0c7763b2e3fbe2e /gnu/packages/check.scm
parentcc6653e7a13d42dbbba398e6b4597b2c544274e6 (diff)
downloadguix-patches-c2e19b6291cc4981e39d01aae85af0899614061d.tar
guix-patches-c2e19b6291cc4981e39d01aae85af0899614061d.tar.gz
gnu: python-pylint: Udpate to 2.5.2.
* gnu/packages/check.scm (python-pylint): Update to 2.5.2. [arguments]: New field. (python2-pylint)[arguments]: Do not inherit #:tests?. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7d7fd189bc..8d99e67514 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1887,12 +1887,10 @@ unit tests and failing them if the unit test module does not exercise all
statements in the module it tests.")
(license license:gpl3+)))
-;; Further releases, up to 2.4.3, have failing unit tests. See:
-;; https://github.com/PyCQA/pylint/issues/3198.
(define-public python-pylint
(package
(name "python-pylint")
- (version "2.3.1")
+ (version "2.5.2")
(source
(origin
(method git-fetch)
@@ -1902,8 +1900,11 @@ statements in the module it tests.")
(file-name (git-file-name name version))
(sha256
(base32
- "17vvzbcqmkhr4icq5p3737nbiiyj1y3g1pa08n9mb1bsnvxmqq0z"))))
+ "150x679mrlgm1s4ym7irf9mnsjilqyaakss4spc4pbrzkl11agnh"))))
(build-system python-build-system)
+ ;; FIXME: Tests are failing since version 2.4.3, see:
+ ;; https://github.com/PyCQA/pylint/issues/3198.
+ (arguments '(#:tests? #f))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)
@@ -1945,7 +1946,7 @@ possible to write plugins to add your own checks.")
(base32
"02a89d8a47s7nfiv1ady3j0sg2sbyja3np145brarfp5x9qxz9x2"))))
(arguments
- `(,@(package-arguments pylint)
+ `(,@(strip-keyword-arguments '(#:tests?) (package-arguments pylint))
#:phases
(modify-phases %standard-phases
(replace 'check