summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 13:40:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:54 -0400
commitbfe7f4065095fde94a44b511ae74186a2dbe880f (patch)
tree57be92f6518672388494d867213cf9494fc2402f /gnu/packages/check.scm
parent1a564cf1471267894c3360e3a5bf0296be01b75d (diff)
downloadguix-patches-bfe7f4065095fde94a44b511ae74186a2dbe880f.tar
guix-patches-bfe7f4065095fde94a44b511ae74186a2dbe880f.tar.gz
gnu: python-hypothesis-6.23: Update to 6.43.3.
* gnu/packages/check.scm (python-hypothesis-6.23): Update to 6.43.3 and rename to... (python-hypothesis-next): ... this. [propagated-inputs]: Add python-pytest. * gnu/packages/matrix.scm (python-matrix-nio): Adjust accordingly. * gnu/packages/python-web.scm (python-h2): Likewise. * gnu/packages/check.scm (python-hypothesis)[home-page]: Update URL.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 957d7a4262..8e6576208c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2174,20 +2174,24 @@ instantly.")
much larger range of examples than you would ever want to write by hand. It’s
based on the Haskell library, Quickcheck, and is designed to integrate
seamlessly into your existing Python unit testing work flow.")
- (home-page "https://github.com/HypothesisWorks/hypothesis-python")
+ (home-page "https://github.com/HypothesisWorks/hypothesis")
(license license:mpl2.0)
(properties `((python2-variant . ,(delay python2-hypothesis))))))
-(define-public python-hypothesis-6.23
+;;; TODO: Make the default python-hypothesis in the next rebuild cycle.
+(define-public python-hypothesis-next
(package
(inherit python-hypothesis)
- (version "6.23.4")
+ (version "6.43.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "0wp8i9qmd5wl1sq1l2b97fgliyk5fyphssl6j7q5qn5zjlfgi4qs"))))))
+ "0d67dlc5a47i48fxzmji2mnybzby0h1wdscmj54555fghcyp1045"))))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-hypothesis)
+ (append python-pytest))))) ;to satisfy the sanity-check phase
;; This is the last version of Hypothesis that supports Python 2.
(define-public python2-hypothesis