summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-03 19:41:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-03 19:41:05 +0100
commit982eff9e841f3539e4ecf93669435a290bfde571 (patch)
treeb1e3f6fc85c6c35c264f091eb2fc5cff8514c230 /gnu/packages/check.scm
parent7ba6d70e4528201151195e1ed2175ee4828bdb2f (diff)
parent7158fe4ded47a599ceb8d556132ba83fcc686962 (diff)
downloadguix-patches-982eff9e841f3539e4ecf93669435a290bfde571.tar
guix-patches-982eff9e841f3539e4ecf93669435a290bfde571.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm34
1 files changed, 32 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a9b38f329d..fa65104dfb 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -196,7 +196,7 @@ supervised tests.")
multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
-(define-public catch-framework2
+(define-public catch-framework2-1
(package
(name "catch2")
(version "1.12.2")
@@ -216,6 +216,28 @@ multi-paradigm automated test framework for C++ and Objective-C.")
a multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
+(define-public catch-framework2
+ (package
+ (name "catch2")
+ (version "2.1.2")
+ (home-page "https://github.com/catchorg/Catch2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/catchorg/Catch2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14vcckqmbydjsg40ngi6iv999zimysh2l7fmrqj1d7xl990qz233"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("python" ,python-wrapper)))
+ (synopsis "Automated test framework for C++ and Objective-C")
+ (description "Catch2 stands for C++ Automated Test Cases in Headers and is
+a multi-paradigm automated test framework for C++ and Objective-C.")
+ (license license:boost1.0)))
+
(define-public cmdtest
(package
(name "cmdtest")
@@ -1962,7 +1984,15 @@ backported from Python 2.7 for Python 2.4+.")
("python-parse" ,python-parse)
("python-parse-type" ,python-parse-type)))
(arguments
- '(#:test-target "behave_test"))
+ '(#:test-target "behave_test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-library-loading
+ (lambda _
+ ;; Otherwise, tests fail with no module named 'path'
+ (setenv "PYTHONPATH" (string-append (getenv "PYTHONPATH") ":"
+ (getcwd) "/tasks/_vendor"))
+ #t)))))
(home-page "https://github.com/behave/behave")
(synopsis "Python behavior-driven development")
(description