summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-19 14:26:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-19 15:05:45 +0200
commit90afa80dd9f0e78a826c36b9bfa5f745e2290cd9 (patch)
tree61c5af1eb3cdbb1d8441217f32fb495bec451293 /gnu/packages/check.scm
parent4abc50666e0a30baea3e3bf414e60d57916ab2c0 (diff)
downloadguix-patches-90afa80dd9f0e78a826c36b9bfa5f745e2290cd9.tar
guix-patches-90afa80dd9f0e78a826c36b9bfa5f745e2290cd9.tar.gz
gnu: Add python-pytest-timeout.
* gnu/packages/check.scm (python-pytest-timeout): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 82391ac5e1..2a0da625fd 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -925,6 +925,27 @@ result back.")
(define-public python2-pytest-xdist
(package-with-python2 python-pytest-xdist))
+(define-public python-pytest-timeout
+ (package
+ (name "python-pytest-timeout")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-timeout" version))
+ (sha256
+ (base32
+ "1cczcjhw4xx5sjkhxlhc5c1bkr7x6fcyx12wrnvwfckshdvblc2a"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "http://bitbucket.org/pytest-dev/pytest-timeout/")
+ (synopsis "Plugin for py.test to abort hanging tests")
+ (description
+ "This package provides a py.test plugin that aborts hanging tests after a
+timeout has been exceeded.")
+ (license license:expat)))
+
(define-public python-scripttest
(package
(name "python-scripttest")