summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-19 23:06:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-19 23:21:06 +0100
commit8aa59a54e98efbe237a68917f014baf94a490270 (patch)
tree6eaff87ca04acb35cf32f941a4d89ea7f2bb619d /gnu/packages/check.scm
parent719d8d5b93cb9b732eba15a75f1b075735a91062 (diff)
downloadguix-patches-8aa59a54e98efbe237a68917f014baf94a490270.tar
guix-patches-8aa59a54e98efbe237a68917f014baf94a490270.tar.gz
gnu: catch-framework2: Update to 2.1.2.
* gnu/packages/check.scm (catch-framework2): Update to 2.1.2. (catch-framework2-1): New variable. * gnu/packages/cpp.scm (fifo-map)[native-inputs]: Use catch-framework2-1.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6619142b50..f61e96422b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -196,7 +196,7 @@ supervised tests.")
multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
-(define-public catch-framework2
+(define-public catch-framework2-1
(package
(name "catch2")
(version "1.12.2")
@@ -216,6 +216,28 @@ multi-paradigm automated test framework for C++ and Objective-C.")
a multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
+(define-public catch-framework2
+ (package
+ (name "catch2")
+ (version "2.1.2")
+ (home-page "https://github.com/catchorg/Catch2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/catchorg/Catch2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14vcckqmbydjsg40ngi6iv999zimysh2l7fmrqj1d7xl990qz233"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("python" ,python-wrapper)))
+ (synopsis "Automated test framework for C++ and Objective-C")
+ (description "Catch2 stands for C++ Automated Test Cases in Headers and is
+a multi-paradigm automated test framework for C++ and Objective-C.")
+ (license license:boost1.0)))
+
(define-public cmdtest
(package
(name "cmdtest")