summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-24 00:13:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:36 +0100
commit861a265959ca931bab38fe6c1266de8849016820 (patch)
treeca3737ce930e09628d8c6bd27fe9934ef64d1f3a /gnu/packages/check.scm
parent0eb2ce12c03d8608b8cace51132ef72c16d36ef2 (diff)
downloadguix-patches-861a265959ca931bab38fe6c1266de8849016820.tar
guix-patches-861a265959ca931bab38fe6c1266de8849016820.tar.gz
gnu: python-pytest-runner: Update to 5.2.
* gnu/packages/check.scm (python-pytest-runner): Update to 5.2. [arguments]: New field. [native-inputs]: Remove PYTHON-PYTEST-BOOTSTRAP.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b58349fb2e..19147e1afd 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -920,18 +920,28 @@ supports coverage of subprocesses.")
(define-public python-pytest-runner
(package
(name "python-pytest-runner")
- (version "4.4")
+ (version "5.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-runner" version))
(sha256
(base32
- "1x0d9n40lsiphblbs61rdc0d5r31f6vh0vcahqdv0mffakbnrb80"))))
+ "0awll1bva5zy8cspsxcpv7pjcrdf5c6pf56nqn4f74vvmlzfgiwn"))))
(build-system python-build-system)
+ (arguments
+ '(;; FIXME: The test suite requires 'python-flake8' and 'python-black',
+ ;; but that introduces a circular dependency.
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-vv")
+ (format #t "test suite not run~%"))
+ #t)))))
(native-inputs
- `(("python-pytest" ,python-pytest-bootstrap)
- ("python-setuptools-scm" ,python-setuptools-scm)))
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
(home-page "https://github.com/pytest-dev/pytest-runner")
(synopsis "Invoke py.test as a distutils command")
(description