summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 00:00:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:43 -0400
commit6c80abe0977907441df2603a00f0be2fcc4e04f0 (patch)
tree022a42d5b5449a5953f6ee415c13018ae043a8f1 /gnu/packages/check.scm
parent60965e70ed41c2086352f11ad3eedd69b59aec44 (diff)
downloadguix-patches-6c80abe0977907441df2603a00f0be2fcc4e04f0.tar
guix-patches-6c80abe0977907441df2603a00f0be2fcc4e04f0.tar.gz
gnu: Remove python2-pytest-mock.
* gnu/packages/check.scm (python2-pytest-mock): Delete variable. (python-pytest-mock)[properties]: Delete field.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 224c7e62e7..8b77bf77ce 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1401,29 +1401,8 @@ around the patching API provided by the @code{mock} package, but with the
benefit of not having to worry about undoing patches at the end of a test.
The mocker fixture has the same API as @code{mock.patch}, supporting the
same arguments.")
- (properties `((python2-variant . ,(delay python2-pytest-mock))))
(license license:expat)))
-(define-public python2-pytest-mock
- (let ((base (package-with-python2
- (strip-python2-variant python-pytest-mock))))
- (package/inherit base
- (version "1.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-mock" version))
- (sha256
- (base32
- "1i5mg3ff1qk0wqfcxfz60hwy3q5dskdp36i10ckigkzffg8hc3ad"))))
- (arguments
- `(#:python ,python-2))
- (native-inputs
- `(("python2-setuptools-scm" ,python2-setuptools-scm)))
- (propagated-inputs
- `(("python2-mock" ,python2-mock)
- ("python2-pytest" ,python2-pytest))))))
-
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")