summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 22:32:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 22:47:20 -0400
commit5f3a32199a39e9d17f6d020588ddc9f5cf7021b3 (patch)
tree218423ff0fd2efa2fd820428e39f6c3f87e3eba6 /gnu/packages/check.scm
parente7b018b2829b56fc0e659a32982685c636bf1552 (diff)
downloadguix-patches-5f3a32199a39e9d17f6d020588ddc9f5cf7021b3.tar
guix-patches-5f3a32199a39e9d17f6d020588ddc9f5cf7021b3.tar.gz
gnu: python-pyhamcrest: Update to 2.0.2.
* gnu/packages/check.scm (python-pyhamcrest): Update to 2.0.2. [origin]: Use latest tagged release. Reword comment. [native-inputs]: Remove all but the python-pytest input. [propagated-inputs]: Delete field. [phases]{check}: Augment PYTHONPATH via the add-installed-pythonpath procedure.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm65
1 files changed, 26 insertions, 39 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6f50837095..287f633c58 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2702,45 +2702,32 @@ retried.")
(package-with-python2 python-flaky))
(define-public python-pyhamcrest
- ;; The latest release was in 2016 and its test suite does not work with recent
- ;; versions of Pytest. Just take the master branch for now, which seems stable.
- (let ((commit "25fdc5f00bdf3084335353bc9247253098ec4cf2")
- (revision "0"))
- (package
- (name "python-pyhamcrest")
- (version (git-version "1.9.0" revision commit))
- (source (origin
- ;; Tests not distributed from pypi release.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hamcrest/PyHamcrest")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1miqmhhi68vaix8sqc1lvpvbm27bacffxh5anm5cbfsvk7g9n6f3"))))
- (native-inputs ;all native inputs are for tests
- `(("python-pytest-cov" ,python-pytest-cov)
- ("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
- ("python-hypothesis" ,python-hypothesis)))
- (propagated-inputs
- `(("python-six" ,python-six)))
- (build-system python-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (setenv "PYTHONPATH"
- (string-append "build/lib:"
- (getenv "PYTHONPATH")))
- (invoke "pytest" "-vv"))))))
- (home-page "http://hamcrest.org/")
- (synopsis "Hamcrest matchers for Python")
- (description
- "PyHamcrest is a framework for writing matcher objects,
- allowing you to declaratively define \"match\" rules.")
- (license license:bsd-3))))
+ (package
+ (name "python-pyhamcrest")
+ (version "2.0.2")
+ (source (origin
+ (method git-fetch) ;no tests in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/hamcrest/PyHamcrest")
+ (commit (string-append "V" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05kdzlhs2kvj82pfca13qszszcj6dyrk4b9pbr46x06sq2s4qyls"))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (home-page "http://hamcrest.org/")
+ (synopsis "Hamcrest matchers for Python")
+ (description "PyHamcrest is a framework for writing matcher objects,
+allowing you to declaratively define \"match\" rules.")
+ (license license:bsd-3)))
(define-public unittest-cpp
(package