summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 11:00:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:27 -0400
commit5475a267ea2668dd2923b578658e10f031e724a1 (patch)
tree7c49a5610211c37dc5bdd25fa80df397768bdda3 /gnu/packages/check.scm
parent21db2a0848a661883ebc9dfd53c125488541a835 (diff)
downloadguix-patches-5475a267ea2668dd2923b578658e10f031e724a1.tar
guix-patches-5475a267ea2668dd2923b578658e10f031e724a1.tar.gz
gnu: Add python-pytest-mypy.
* gnu/packages/check.scm (python-pytest-mypy): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 335ab7ab11..75b42b945a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2200,6 +2200,27 @@ style test suites, summarizing their results, and providing indication of
failures.")
(license license:ncsa)))
+(define-public python-pytest-mypy
+ (package
+ (name "python-pytest-mypy")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mypy" version))
+ (sha256
+ (base32 "0p5bd4r4gbwk1h7mpx1jkhdwkckapfz24bp9x5mmqb610ps3pylz"))))
+ (build-system python-build-system)
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs
+ (list python-attrs python-filelock python-mypy python-pytest))
+ (home-page "https://github.com/dbader/pytest-mypy")
+ (synopsis "Mypy static type checker plugin for Pytest")
+ (description "@code{pytest-mypi} is a static type checker plugin for
+Pytest that runs the mypy static type checker on your source files as part of
+a Pytest test execution.")
+ (license license:expat)))
+
(define-public python-pytest-pep8
(package
(name "python-pytest-pep8")