summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-20 22:27:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-20 22:38:16 +0200
commit52305b0ab3f7f1cea5e0977cddea5b929e8260c1 (patch)
tree64580e6a05d1100f537e815fa37e3f2f8bb4fd9d /gnu/packages/check.scm
parent23ff7239f20f497f52bf61b478ec6bd2de7addc4 (diff)
downloadguix-patches-52305b0ab3f7f1cea5e0977cddea5b929e8260c1.tar
guix-patches-52305b0ab3f7f1cea5e0977cddea5b929e8260c1.tar.gz
gnu: python-testpath: Use 'git-fetch'.
* gnu/packages/check.scm (python-testpath)[source]: Use 'git-fetch'.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d42b743f6a..7a546b17ce 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1254,13 +1254,14 @@ C/C++, R, and more, and uploads it to the @code{codecov.io} service.")
(version "0.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/jupyter/testpath/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jupyter/testpath")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "04kh3fgvmqz6cfcw79q70qwjz7ib7lxm27cc548iy2rpr33qqf55"))))
+ "0r4iiizjql6ny1ln7ciw7rrbjadz1s9zrf2hl0xkgnh3ypd8936f"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; this package does not even have a setup.py