summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-26 14:44:48 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-29 01:05:28 -0400
commit48461816e4886453726a81d98a1d6846fa709579 (patch)
tree317a91b9740ba3614b0a31f74159eee91e862528 /gnu/packages/check.scm
parentb1ef8b410c334debee1e9ff577a69c6a21220100 (diff)
downloadguix-patches-48461816e4886453726a81d98a1d6846fa709579.tar
guix-patches-48461816e4886453726a81d98a1d6846fa709579.tar.gz
gnu: python-pytest-mock: Update to 3.6.1 and run test suite.
* gnu/packages/check.scm (python-pytest-mock): Update to 3.6.1. [phases]{check}: Override to run test suite. [propagated-inputs]: Add python-pytest-asyncio.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm30
1 files changed, 22 insertions, 8 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 43689c3670..3dc4319160 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1261,19 +1261,33 @@ contacting the real http server.")
(define-public python-pytest-mock
(package
(name "python-pytest-mock")
- (version "1.10.1")
+ (version "3.6.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-mock" version))
- (sha256
- (base32
- "1i5mg3ff1qk0wqfcxfz60hwy3q5dskdp36i10ckigkzffg8hc3ad"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mock" version))
+ (sha256 (base32
+ "0qhfmd05z3g88bnwq6644jl6p5wy01i4yy7h8883z9jjih2pl8a0"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ ;; Skip the assertion rewriting tests, which don't work in the
+ ;; presence of read-only Python modules (a limitation of
+ ;; Pytest). Also skip the "test_standalone_mock" test, which
+ ;; can only work when 'python-mock' is not available
+ ;; (currently propagated by Pytest 5).
+ (invoke "pytest" "--assert=plain"
+ "-k" "not test_standalone_mock")))))))
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)))
(propagated-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)))
(home-page "https://github.com/pytest-dev/pytest-mock/")
(synopsis "Thin-wrapper around the mock package for easier use with py.test")
(description