summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSébastien Lerique <sl@eauchat.org>2021-10-15 11:40:12 +0900
committerLars-Dominik Braun <lars@6xq.net>2021-10-18 09:02:36 +0200
commit23c9d22e118db2362c8f0132a49c3004fa668b12 (patch)
treeb1eb20cfc39149039e9cad45a9ae6955ab768186 /gnu/packages/check.scm
parent473ea161a15a13e7d5e7e0724693c1931ff8daaa (diff)
downloadguix-patches-23c9d22e118db2362c8f0132a49c3004fa668b12.tar
guix-patches-23c9d22e118db2362c8f0132a49c3004fa668b12.tar.gz
gnu: Add python-hypothesis-6.23.
* gnu/packages/check.scm (python-hypothesis-6.23): New variable. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4701d61a9e..1f9cc26913 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2154,6 +2154,17 @@ seamlessly into your existing Python unit testing work flow.")
"0sy1v6nyxg4rjcf3rlr8nalb7wqd9nccpb2lzkchbj5an13ysf1h"))))
(home-page "https://github.com/HypothesisWorks/hypothesis")))
+(define-public python-hypothesis-6.23
+ (package
+ (inherit python-hypothesis)
+ (version "6.23.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hypothesis" version))
+ (sha256
+ (base32
+ "0lqhfrqsd81apchz93pdqfn85kx0p790w8hhd9qq85692rwja6xp"))))))
+
;; This is the last version of Hypothesis that supports Python 2.
(define-public python2-hypothesis
(let ((hypothesis (package-with-python2