summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 13:09:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 13:09:57 +0300
commit138c122fef42e49e83b957a1cdf3a7590768aa2a (patch)
tree12204302f262eccdcf17026cb642927cbafdf440 /gnu/packages/check.scm
parent7a0077d7f39f7d77b3afb57311c03cded68620a9 (diff)
downloadguix-patches-138c122fef42e49e83b957a1cdf3a7590768aa2a.tar
guix-patches-138c122fef42e49e83b957a1cdf3a7590768aa2a.tar.gz
gnu: Add python-pytest-6.1.
* gnu/packages/check.scm (python-pytest-6.1): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index cc2cd5e1f8..da13018a91 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1031,6 +1031,17 @@ and many external plugins.")
(license license:expat)
(properties `((python2-variant . ,(delay python2-pytest))))))
+(define-public python-pytest-6.1
+ (package
+ (inherit python-pytest)
+ (version "6.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32 "0gl2sdm322vzmsh5k4f8kj9raiq2y7kdinnca4m45ifvii5fk9y0"))))))
+
(define-public python-pytest-6 python-pytest)
;; Pytest 4.x are the last versions that support Python 2.