summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-12 22:00:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-12 22:00:52 +0100
commit12878d12acccf83ef3258a53a01f851088f0aa9e (patch)
tree47f875b50bd7714251256475317e96f4e6d73f55 /gnu/packages/check.scm
parent17c3e0d85d9c1a6b4c09d09dd9238297b6165a2f (diff)
parent7b046b1bdc0b1cbc50428d4e08136a110f0a12af (diff)
downloadguix-patches-12878d12acccf83ef3258a53a01f851088f0aa9e.tar
guix-patches-12878d12acccf83ef3258a53a01f851088f0aa9e.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 937e4e094c..5bf849d666 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1414,6 +1414,30 @@ normally the case.")
(define-public python2-pytest-subtesthack
(package-with-python2 python-pytest-subtesthack))
+(define-public python-pytest-sugar
+ (package
+ (name "python-pytest-sugar")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-sugar" version))
+ (sha256
+ (base32
+ "1asq7yc4g8bx2sn7yy974mhc9ywvaihasjab4inkirdwn9s7mn7w"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-packaging" ,python-packaging)
+ ("python-pytest" ,python-pytest)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page "https://pivotfinland.com/pytest-sugar/")
+ (synopsis "Plugin for pytest that changes the default look and feel")
+ (description
+ "@code{pytest-sugar} is a plugin for py.test that changes the default
+look and feel of py.test, using a progress bar and showing failures and errors
+instantly.")
+ (license license:bsd-3)))
+
(define-public python-hypothesis
(package
(name "python-hypothesis")