summaryrefslogtreecommitdiff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/certs.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index d09778f6da..fc4f4f2686 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -76,7 +76,7 @@
#:install-plan
'(("." "etc/desec" #:include ("hook.sh")))))
(inputs
- `(("curl" ,curl)))
+ (list curl))
(synopsis "Certbot DNS challenge automatization for deSEC")
(description "The deSEC can be used to obtain certificates with certbot
DNS ownership verification. With the help of this hook script, you can obtain
@@ -133,8 +133,7 @@ that was originally contributed to Debian.")
(build-system gnu-build-system)
(outputs '("out"))
(native-inputs
- `(("certdata2pem" ,certdata2pem)
- ("openssl" ,openssl)))
+ (list certdata2pem openssl))
(inputs '())
(propagated-inputs '())
(arguments
@@ -201,8 +200,7 @@ taken from the NSS package and thus ultimately from the Mozilla project.")
(string-append openssl "/bin/c_rehash")
".")))))
(native-inputs
- `(("openssl" ,openssl)
- ("perl" ,perl))) ;for 'c_rehash'
+ (list openssl perl)) ;for 'c_rehash'
(inputs
`(; The Let's Encrypt root certificate, "ISRG Root X1".
("isrgrootx1.pem"