summaryrefslogtreecommitdiff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:27:24 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:43:20 -0400
commit4530e854f1ca25492a7dda2d0d438d222ff53eb4 (patch)
tree53224c6aeba9633a5ff85f2ec4b85e17fbc3cfcf /gnu/packages/certs.scm
parentdbf5b1186ea70efcaefb205d91e81a5e70e87fff (diff)
downloadguix-patches-4530e854f1ca25492a7dda2d0d438d222ff53eb4.tar
guix-patches-4530e854f1ca25492a7dda2d0d438d222ff53eb4.tar.gz
gnu: le-certs: Use invoke.
* gnu/packages/certs.scm (le-certs)[arguments]: Use invoke in the builder.
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 03549af0ef..bb8facbc89 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -170,10 +170,9 @@ taken from the NSS package and thus ultimately from the Mozilla project.")
;; Create hash symlinks suitable for OpenSSL ('SSL_CERT_DIR' and
;; similar.)
(chdir (string-append %output "/etc/ssl/certs"))
- (unless (zero? (system* (string-append perl "/bin/perl")
- (string-append openssl "/bin/c_rehash")
- "."))
- (error "'c_rehash' failed" openssl))))))
+ (invoke (string-append perl "/bin/perl")
+ (string-append openssl "/bin/c_rehash")
+ ".")))))
(native-inputs
`(("openssl" ,openssl)
("perl" ,perl))) ;for 'c_rehash'