summaryrefslogtreecommitdiff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-27 20:59:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-27 20:59:53 +0200
commit11a7bfbc466382eec17c427b8759efc90355dbb1 (patch)
tree4a8a5ad1be7dcd8a8b3cced0ad541ee864d24229 /gnu/packages/certs.scm
parent1001baa1e8ba2837eb30495f8839f59b70af997f (diff)
downloadguix-patches-11a7bfbc466382eec17c427b8759efc90355dbb1.tar
guix-patches-11a7bfbc466382eec17c427b8759efc90355dbb1.tar.gz
gnu: certdata2pem: Fix cross compiling.
* gnu/packages/certs.scm (certdata2pem)[arguments]: Use cc-for-target.
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 9b8237055b..5bdf3b5a4a 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -25,6 +25,7 @@
(define-module (gnu packages certs)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
@@ -53,7 +54,8 @@
(delete 'configure)
(replace 'build
(lambda _
- (invoke "gcc" "certdata2pem.c" "-o" "certdata2pem")))
+ (invoke ,(cc-for-target) "certdata2pem.c"
+ "-o" "certdata2pem")))
(delete 'check) ;no test suite
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)