summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-05 11:38:03 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-04-14 19:01:10 +0200
commit9a018b9b938471f8aea66f06324c8167ca08878a (patch)
tree38f2e317889dfc18dbd35362be0fef2cf375271b /gnu/packages/cdrom.scm
parentba5c154e962e3cb66b26b59ee1c1143a448cdd8e (diff)
downloadguix-patches-9a018b9b938471f8aea66f06324c8167ca08878a.tar
guix-patches-9a018b9b938471f8aea66f06324c8167ca08878a.tar.gz
gnu: Add cdemu-client.
* gnu/packages/cdrom.scm (cdemu-client): New variable.
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 1bef2ef5e8..2193a94f86 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -921,3 +921,50 @@ the data stored in various image formats.")
(description "CDemu is a software suite designed to emulate an optical
drive and disc (including CD-ROMs and DVD-ROMs).")
(license gpl2+)))
+
+(define-public cdemu-client
+ (package
+ (name "cdemu-client")
+ (version "3.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://downloads.sourceforge.net/cdemu/cdemu-client-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1zwz987pb2pakfk9kz8a6xa9hq1ip48cn4ryl9z85dik8k2sizm9"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("python" ,python)
+ ("python-pygobject" ,python-pygobject)
+ ("cdemu-daemon" ,cdemu-daemon)))
+ (arguments
+ ;; No tests.
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'patch-shebang
+ (lambda* (#:key outputs #:allow-other-keys)
+ (patch-shebang (string-append (assoc-ref outputs "out")
+ "/bin/cdemu"))
+ #t))
+ (add-after 'patch-shebang 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/cdemu")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))
+ #t))))))
+ (home-page "https://cdemu.sourceforge.io/")
+ (synopsis "Command-line client for controlling cdemu-daemon")
+ (description "CDEmu client is a simple command-line client for controlling
+CDEmu daemon.
+
+It provides a way to perform the key tasks related to controlling the CDEmu
+daemon, such as loading and unloading devices, displaying devices' status and
+retrieving/setting devices' debug masks.")
+ (license gpl2+)))