summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 00:39:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 00:39:50 +0200
commit49176f0e4684a9b50cf75b4a0d1e9c3edb0074d2 (patch)
treef9e26941f7baa301a1267697e2eb27b935e7c52e /gnu/packages/cdrom.scm
parent2782cb38a3bc68c530d6e95f6834ae0cb7ed16aa (diff)
downloadguix-patches-49176f0e4684a9b50cf75b4a0d1e9c3edb0074d2.tar
guix-patches-49176f0e4684a9b50cf75b4a0d1e9c3edb0074d2.tar.gz
gnu: cdparanoia: Don't build in parallel.
* gnu/packages/cdrom.scm (cdparanoia)[arguments]: Disable #:parallel-build?. Reported by Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 443d7455a7..66a259f261 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -231,13 +231,15 @@ files.")
'(begin
;; Make libraries respect LDFLAGS.
(substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
- (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname"))
- #t))))
+ (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname"))))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there is no check target
#:configure-flags ; Add $libdir to the RUNPATH of all the executables.
- (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
+ (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ ;; Building in parallel is flaky: “ld: […]/cachetest.c:393: undefined
+ ;; reference to `paranoia_free'”.
+ #:parallel-build? #f))
(home-page "https://www.xiph.org/paranoia/")
(synopsis "Audio CD reading utility")
(description "Cdparanoia retrieves audio tracks from CDDA capable CDROM