summaryrefslogtreecommitdiff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-10 00:12:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-10 06:48:27 +0300
commit9d5448f35f8d933c7dd54427bf6b3186a5154919 (patch)
tree2337499d3797bd522ffc76c987d017641bde9587 /gnu/packages/ccache.scm
parente9fd10a83bc5aa799fac058bab0463361923e632 (diff)
downloadguix-patches-9d5448f35f8d933c7dd54427bf6b3186a5154919.tar
guix-patches-9d5448f35f8d933c7dd54427bf6b3186a5154919.tar.gz
gnu: ccache: Update to 3.2.5.
* gnu/packages/ccache.scm (ccache): Update to 3.2.5. [native-inputs]: Add which.
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index d84ac80bbf..01db7ae57d 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,7 +29,7 @@
(define-public ccache
(package
(name "ccache")
- (version "3.2.4")
+ (version "3.2.5")
(source
(origin
(method url-fetch)
@@ -36,16 +37,18 @@
version ".tar.xz"))
(sha256
(base32
- "0pga3hvd80f2p7mz88jmmbwzxh4vn5ihyjx5f6na8y2fclzsjg8w"))))
+ "11db1g109g0g5si0s50yd99ja5f8j4asxb081clvx78r9d9i2w0i"))))
(build-system gnu-build-system)
- (native-inputs `(("perl" ,perl))) ;for test.sh
+ (native-inputs `(("perl" ,perl) ;for test.sh
+ ("which" ,(@ (gnu packages base) which))))
(inputs `(("zlib" ,zlib)))
(arguments
'(#:phases (alist-cons-before
'check 'setup-tests
(lambda _
(substitute* '("test/test_hashutil.c" "test.sh")
- (("#!/bin/sh") (string-append "#!" (which "sh"))))
+ (("#!/bin/sh") (string-append "#!" (which "sh")))
+ (("which") (which "which")))
#t)
%standard-phases)))
(home-page "https://ccache.samba.org/")