summaryrefslogtreecommitdiff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 16:09:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 19:23:49 +0200
commit9b9c74eaa79cf69ab1b612e5ab02b93d93f2516c (patch)
tree5066b09ff164b9e1058020644596c02caaa1cb8b /gnu/packages/ccache.scm
parentdfa6e6cad57c20ab87c8aaf289acf35b6e60608f (diff)
downloadguix-patches-9b9c74eaa79cf69ab1b612e5ab02b93d93f2516c.tar
guix-patches-9b9c74eaa79cf69ab1b612e5ab02b93d93f2516c.tar.gz
gnu: ccache: Update to 4.4.2.
* gnu/packages/ccache.scm (ccache): Update to 4.4.2. [source]: Remove patch. [arguments]: Substitute nonexistent compgen. * gnu/packages/patches/ccache-fix-basedir-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 844a0d51a5..44b0ef606a 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -31,16 +31,14 @@
(define-public ccache
(package
(name "ccache")
- (version "4.4.1")
+ (version "4.4.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/ccache/ccache/releases/download/v"
version "/ccache-" version ".tar.xz"))
(sha256
- (base32 "0nc1mlmj92lfa25d12nzf5n55az6zfx38n0z1qqkkzjxn6sxzmpb"))
- (patches
- (search-patches "ccache-fix-basedir-test.patch"))))
+ (base32 "186b5lfbdd48cvbxqv2yh93pgr8lhahl1jzw00k2rmjzmbxwl04j"))))
(build-system cmake-build-system)
(native-inputs `(("perl" ,perl) ; for test/run
("which" ,(@ (gnu packages base) which))))
@@ -53,9 +51,13 @@
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'setup-tests
+ (add-before 'configure 'fix-shell
+ ;; Run early whilst we're still in the source directory.
(lambda _
- (substitute* '("unittest/test_hashutil.cpp" "test/suites/base.bash")
+ (substitute* (list "test/run"
+ "test/suites/base.bash"
+ "unittest/test_hashutil.cpp")
+ (("compgen -e") "env | cut -d= -f1")
(("#!/bin/sh") (string-append "#!" (which "sh"))))))
(add-before 'check 'set-home
;; Tests require a writable HOME.