summaryrefslogtreecommitdiff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-27 19:43:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-28 02:15:35 +0200
commit85d757b53d5ed0e796759373e67a2608766e70f7 (patch)
tree1d29237b462bf7193dfba41a4bebf3fa96a54294 /gnu/packages/ccache.scm
parent134e1b12f26b00237b1ed99caf6a8c6584c10c76 (diff)
downloadguix-patches-85d757b53d5ed0e796759373e67a2608766e70f7.tar
guix-patches-85d757b53d5ed0e796759373e67a2608766e70f7.tar.gz
gnu: ccache: Update to 4.4.1.
* gnu/packages/ccache.scm (ccache): Update to 4.4.1. [source]: Add patch. [arguments]: Remove explicit #t return values from phases. * gnu/packages/patches/ccache-fix-basedir-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 77098658cf..844a0d51a5 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -31,22 +31,23 @@
(define-public ccache
(package
(name "ccache")
- (version "4.4")
+ (version "4.4.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/ccache/ccache/releases/download/v"
version "/ccache-" version ".tar.xz"))
(sha256
- (base32 "0qbmcs6c3m071vsd1ppa31r8s0dzpaw5y38z8ga1bz48rwpfl2xl"))))
+ (base32 "0nc1mlmj92lfa25d12nzf5n55az6zfx38n0z1qqkkzjxn6sxzmpb"))
+ (patches
+ (search-patches "ccache-fix-basedir-test.patch"))))
(build-system cmake-build-system)
(native-inputs `(("perl" ,perl) ; for test/run
("which" ,(@ (gnu packages base) which))))
(inputs `(("zlib" ,zlib)
("zstd" ,zstd "lib")))
(arguments
- '(;; Disable redis backend explicitly. Build system insists on present dependency
- ;; or on explicit flag.
+ '( ;; The Redis backend must be explicitly disabled to build without Redis.
#:configure-flags
'("-DREDIS_STORAGE_BACKEND=OFF")
@@ -55,13 +56,11 @@
(add-before 'configure 'setup-tests
(lambda _
(substitute* '("unittest/test_hashutil.cpp" "test/suites/base.bash")
- (("#!/bin/sh") (string-append "#!" (which "sh"))))
- #t))
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))))
(add-before 'check 'set-home
;; Tests require a writable HOME.
(lambda _
- (setenv "HOME" (getenv "TMPDIR"))
- #t)))))
+ (setenv "HOME" (getenv "TMPDIR")))))))
(home-page "https://ccache.dev/")
(synopsis "Compiler cache")
(description