summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-08-14 13:38:33 -0400
committerLeo Famulari <leo@famulari.name>2016-08-29 18:39:44 -0400
commitbc8273d0c26e57d9039c763a7b883474be3026ed (patch)
tree6052774be7099de2bd5cb43443c53f675d0b03ba /gnu/packages/calendar.scm
parentf2f5335393d6d839058485f727e72d77cbf5f5ae (diff)
downloadguix-patches-bc8273d0c26e57d9039c763a7b883474be3026ed.tar
guix-patches-bc8273d0c26e57d9039c763a7b883474be3026ed.tar.gz
gnu: khal: Update to 0.8.3.
* gnu/packages/calendar.scm (khal): Update to 0.8.3. [source]: Remove snippet. [arguments]: Remove 'disable-tests' phase. [native-inputs]: Add python-pytest-cov and python-freezegun. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm33
1 files changed, 5 insertions, 28 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 3b5aba72c8..7f3d05d08e 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,42 +81,16 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.7.0")
+ (version "0.8.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
(sha256
(base32
- "00llxj7cv31mjsx0j6zxmyi9s1q20yvfkn025xcy8cv1ylfwic66"))
- (modules '((guix build utils)))
- ;; Patch broken path in 'doc' Makefile.
- ;; Patch sent upstream: https://github.com/geier/khal/pull/307
- (snippet
- '(substitute* "doc/source/Makefile"
- (("../../../khal/khal/settings/khal.spec")
- "../../khal/settings/khal.spec" )))))
+ "1qryqs5d8jsl7j22pjjfkfdi4m8m3nn3n44b890pq85xkw599ihy"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'disable-tests
- (lambda _
- ;; Bug reported for test_only_update_old_event:
- ;; https://github.com/geier/khal/issues/309
- (substitute* "tests/khalendar_test.py"
- (("test_only_update_old_event")
- "disabled_only_update_old_event"))
-
- ;; Bug reported for test_dt_two_tz:
- ;; https://github.com/pimutils/khal/issues/382
- (substitute* "tests/event_test.py"
- (("test_dt_two_tz")
- "disabled_dt_two_tz"))
- ;; Another timezone / DST issue:
- ;; https://github.com/pimutils/khal/issues/146
- (substitute* "tests/event_test.py"
- (("test_raw_dt")
- "disabled_raw_dt"))))
-
;; Building the manpage requires khal to be installed.
(add-after 'install 'manpage
(lambda* (#:key outputs #:allow-other-keys)
@@ -136,9 +111,11 @@ data units.")
(zero? (system* "py.test" "tests")))))))
(native-inputs
`(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
("python-setuptools-scm" ,python-setuptools-scm)
;; Required for tests
("tzdata" ,tzdata)
+ ("python-freezegun" ,python-freezegun)
;; Required to build manpage
("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)
("python-sphinx" ,python-sphinx)))