summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/calendar.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm66
1 files changed, 29 insertions, 37 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 6c815daf7d..129eb58aa0 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -80,7 +80,7 @@
;; Install pkg-config files
;; https://github.com/HowardHinnant/date/pull/538
(search-patches "date-output-pkg-config-files.patch"))))
- (inputs `(("tzdata" ,tzdata)))
+ (inputs (list tzdata))
(build-system cmake-build-system)
(arguments
'(#:configure-flags (list "-DUSE_SYSTEM_TZ_DB=ON"
@@ -158,19 +158,17 @@ the <tz.h> library for handling time zones and leap seconds.")
(("\\\"/usr/share/lib/zoneinfo\\\"") "")))
#t)))))
(native-inputs
- `(("docbook-xml" ,docbook-xml-4.3)
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc/stable)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
+ (list docbook-xml-4.3
+ gobject-introspection
+ gtk-doc/stable
+ perl
+ pkg-config
+ vala))
(inputs
- `(("glib" ,glib)
- ("libxml2" ,libxml2)
- ("tzdata" ,tzdata)))
+ (list glib libxml2 tzdata))
(propagated-inputs
;; In Requires.private of libical.pc.
- `(("icu4c" ,icu4c)))
+ (list icu4c))
(home-page "https://libical.github.io/libical/")
(synopsis "iCalendar protocols and data formats implementation")
(description
@@ -204,23 +202,22 @@ data units.")
(string-append (assoc-ref outputs "out") "/share/man/man1"))
#t)))))
(native-inputs
- `(("python-setuptools-scm" ,python-setuptools-scm)
- ;; Required to build manpage
- ("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)
- ("python-sphinx" ,python-sphinx)))
+ (list python-setuptools-scm
+ ;; Required to build manpage
+ python-sphinxcontrib-newsfeed python-sphinx))
(inputs
- `(("sqlite" ,sqlite)
- ("python-configobj" ,python-configobj)
- ("python-dateutil" ,python-dateutil)
- ("python-icalendar" ,python-icalendar)
- ("python-tzlocal" ,python-tzlocal)
- ("python-urwid" ,python-urwid)
- ("python-pytz" ,python-pytz)
- ("python-setproctitle" ,python-setproctitle)
- ("python-atomicwrites" ,python-atomicwrites)
- ("python-click" ,python-click)
- ("python-click-log" ,python-click-log)
- ("python-pyxdg" ,python-pyxdg)))
+ (list sqlite
+ python-configobj
+ python-dateutil
+ python-icalendar
+ python-tzlocal
+ python-urwid
+ python-pytz
+ python-setproctitle
+ python-atomicwrites
+ python-click
+ python-click-log
+ python-pyxdg))
(synopsis "Console calendar program")
(description "Khal is a standards based console calendar program,
able to synchronize with CalDAV servers through vdirsyncer.")
@@ -275,10 +272,7 @@ able to synchronize with CalDAV servers through vdirsyncer.")
(list "bin/cm2rem.tcl"
"bin/tkremind"))))))))
(inputs
- `(("inetutils" ,inetutils)
- ("tcl" ,tcl)
- ("tcllib" ,tcllib)
- ("tk" ,tk)))
+ (list inetutils tcl tcllib tk))
(home-page "https://dianne.skoll.ca/projects/remind/")
(synopsis "Sophisticated calendar and alarm program")
(description
@@ -347,9 +341,9 @@ and ruby. It includes two illustrative command-line programs, @code{hcal} and
#t))))
#:tests? #f)) ; no tests
(native-inputs
- `(("perl" ,perl))) ; pod2man
+ (list perl)) ; pod2man
(inputs
- `(("qtbase" ,qtbase-5)))
+ (list qtbase-5))
(home-page "https://www.toastfreeware.priv.at/confclerk")
(synopsis "Offline conference schedule application")
(description
@@ -423,11 +417,9 @@ traditional Chinese characters.")
"1qyf65l088dqsz25hm6s1cv18j52yaias0llqvpqwjfnvssa5cxg"))
(modules '((guix build utils)))))
(build-system gnu-build-system)
- (inputs `(("gtk+" ,gtk+)))
+ (inputs (list gtk+))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake pkg-config))
(home-page "https://dmedvinsky.github.io/gsimplecal/")
(synopsis "Lightweight calendar applet")
(description "@command{gsimplecal} is a lightweight calendar application