summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-07 16:03:00 -0500
committerLeo Famulari <leo@famulari.name>2017-03-07 16:37:21 -0500
commit3391e2a0783ee098b7f521ef54a469f025805293 (patch)
tree1676830a7eb7ce84cc5ec984faf072e7fa855859 /gnu/packages/calendar.scm
parentf11275c9e52bca7964c86f3c7d9daee2dd4771a0 (diff)
downloadguix-patches-3391e2a0783ee098b7f521ef54a469f025805293.tar
guix-patches-3391e2a0783ee098b7f521ef54a469f025805293.tar.gz
gnu: khal: Update to 0.9.3.
* gnu/packages/calendar.scm (khal): Update to 0.9.3. [native-inputs]: Use python-pytest-2.9.2.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 7831870c55..1e9a93ca93 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -84,13 +84,13 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.9.2")
+ (version "0.9.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
(sha256
(base32
- "1ryh5c7408w8gpql5s9mkxkvz1ngnds3xm43p7r96ynx8prr9swp"))))
+ "1iva6cw2x3p2jzjj6bsyx7lc7yxin4fsd37j9c96j07x16p4imyl"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -112,7 +112,8 @@ data units.")
"/share/zoneinfo/Zulu"))
(zero? (system* "py.test" "tests")))))))
(native-inputs
- `(("python-pytest" ,python-pytest)
+ ;; XXX Uses tmpdir_factory, introduced in pytest 2.8.
+ `(("python-pytest" ,python-pytest-2.9.2)
("python-pytest-cov" ,python-pytest-cov)
("python-setuptools-scm" ,python-setuptools-scm)
;; Required for tests