summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /gnu/packages/calendar.scm
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm53
1 files changed, 15 insertions, 38 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index e4fb7abcd6..93303d632f 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -178,26 +178,17 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.10.1")
+ (version "0.10.2")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "khal" version))
- (sha256
- (base32
- "1r8bkgjwkh7i8ygvsv51h1cnax50sb183vafg66x5snxf3dgjl6l"))
- (patches
- (list
- (origin
- (method url-fetch)
- ;; This patch fixes an issue with python-urwid-2.1.0
- (uri "https://github.com/pimutils/khal/commit/2c5990c2de2015b251ba23617faa40ee11b8c22a.patch")
- (file-name "khal-compat-urwid-2.1.0.patch")
- (sha256
- (base32
- "11nd8hkjz68imwqqn0p54zmb53z2pfxmzchaviy7jc1ky5s9l663")))))))
+ (method url-fetch)
+ (uri (pypi-uri "khal" version))
+ (sha256
+ (base32
+ "11qhrga44knlnp88py9p547d4nr5kn041d2nszwa3dqw7mf22ks9"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(#:tests? #f ; The test suite is unreliable. See <https://bugs.gnu.org/44197>
+ #:phases (modify-phases %standard-phases
;; Building the manpage requires khal to be installed.
(add-after 'install 'manpage
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -207,28 +198,9 @@ data units.")
(install-file
"doc/build/man/khal.1"
(string-append (assoc-ref outputs "out") "/share/man/man1"))
- #t))
- (add-before 'check 'fix-tests
- (lambda _
- ;; Reported upstream: <https://github.com/pimutils/khal/issues/947>.
- (substitute* "tests/cli_test.py"
- (("Invalid value for \"\\[ICS\\]\"") "Invalid value for \\'[ICS]\\'"))
- #t))
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The tests require us to choose a timezone.
- (setenv "TZ"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo/Zulu"))
- (invoke "py.test" "tests"))))))
+ #t)))))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-setuptools-scm" ,python-setuptools-scm)
- ;; Required for tests
- ("python-freezegun" ,python-freezegun)
- ("tzdata" ,tzdata-for-tests)
- ("vdirsyncer" ,vdirsyncer)
+ `(("python-setuptools-scm" ,python-setuptools-scm)
;; Required to build manpage
("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)
("python-sphinx" ,python-sphinx)))
@@ -239,6 +211,11 @@ data units.")
("python-icalendar" ,python-icalendar)
("python-tzlocal" ,python-tzlocal)
("python-urwid" ,python-urwid)
+ ("python-pytz" ,python-pytz)
+ ("python-setproctitle" ,python-setproctitle)
+ ("python-atomicwrites" ,python-atomicwrites)
+ ("python-click" ,python-click)
+ ("python-click-log" ,python-click-log)
("python-pyxdg" ,python-pyxdg)))
(synopsis "Console calendar program")
(description "Khal is a standards based console calendar program,