summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-19 23:19:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:59 +0100
commit3221207417fa48d0b954520450980812932b804c (patch)
treebec930d8153d91462709771a2814bb7b44fbe638 /gnu/packages/calendar.scm
parent632735f215f5b136ae79914af2eb42b15eebaa11 (diff)
downloadguix-patches-3221207417fa48d0b954520450980812932b804c.tar
guix-patches-3221207417fa48d0b954520450980812932b804c.tar.gz
gnu: khal: Fix build.
The old one was plain wrong and only worked by luck since the old python build system did manipulate PYTHONPATH. * gnu/packages/calendar.scm(khal)[phase manpage]: Use add-installed-pythonpath.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 306c949066..447dcd698e 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -96,10 +96,9 @@ data units.")
`(#:phases (modify-phases %standard-phases
;; Building the manpage requires khal to be installed.
(add-after 'install 'manpage
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "PYTHONPATH"
- (string-append
- (getenv "PYTHONPATH") ":" (assoc-ref outputs "out")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
(zero? (system* "make" "--directory=doc/" "man"))
(install-file
"doc/build/man/khal.1"