summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-23 09:50:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-07-23 11:04:23 +0300
commit2597e47d9ef8bb868e341f6d1c01b76d81a9ae6b (patch)
tree0597b108f3f9771160000c738b9e545466d85f7d /gnu/packages/calendar.scm
parent0b5960df47a288a688dfac8e48eb9281d09449dc (diff)
downloadguix-patches-2597e47d9ef8bb868e341f6d1c01b76d81a9ae6b.tar
guix-patches-2597e47d9ef8bb868e341f6d1c01b76d81a9ae6b.tar.gz
gnu: khal: Fix a failing test.
* gnu/packages/calendar.scm (khal)[arguments]: Fix a failing test. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 726687d488..53c73c969d 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com
;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -195,6 +196,12 @@ data units.")
"doc/build/man/khal.1"
(string-append (assoc-ref outputs "out") "/share/man/man1"))
#t))
+ (add-before 'check 'fix-tests
+ (lambda _
+ ;; Reported upstream: <https://github.com/pimutils/khal/issues/947>.
+ (substitute* "tests/cli_test.py"
+ (("Invalid value for \"\\[ICS\\]\"") "Invalid value for \\'[ICS]\\'"))
+ #t))
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
;; The tests require us to choose a timezone.