summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2020-10-26 13:15:49 -0400
committerLeo Famulari <leo@famulari.name>2020-10-26 13:32:54 -0400
commit21955a54da2bc171f2745486f62aceeacea7993a (patch)
tree3992a5de970a4a8d833ea3698f37234a28db0f4c /gnu/packages/calendar.scm
parent465a951c2444e408289ca16c18fbd1488b50f293 (diff)
downloadguix-patches-21955a54da2bc171f2745486f62aceeacea7993a.tar
guix-patches-21955a54da2bc171f2745486f62aceeacea7993a.tar.gz
gnu: khal: Update to 0.10.2.
* gnu/packages/calendar.scm (khal): Update to 0.10.2. [source]: Drop upstream patches. [arguments]: Drop substitute* for bug fixed upstream and ignore failing test in 'check. [inputs]: Add missing inputs. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm46
1 files changed, 18 insertions, 28 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 1dde978d72..dabf8bfb15 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -168,23 +168,13 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.10.1")
+ (version "0.10.2")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "khal" version))
- (sha256
- (base32
- "1r8bkgjwkh7i8ygvsv51h1cnax50sb183vafg66x5snxf3dgjl6l"))
- (patches
- (list
- (origin
- (method url-fetch)
- ;; This patch fixes an issue with python-urwid-2.1.0
- (uri "https://github.com/pimutils/khal/commit/2c5990c2de2015b251ba23617faa40ee11b8c22a.patch")
- (file-name "khal-compat-urwid-2.1.0.patch")
- (sha256
- (base32
- "11nd8hkjz68imwqqn0p54zmb53z2pfxmzchaviy7jc1ky5s9l663")))))))
+ (method url-fetch)
+ (uri (pypi-uri "khal" version))
+ (sha256
+ (base32
+ "11qhrga44knlnp88py9p547d4nr5kn041d2nszwa3dqw7mf22ks9"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -198,19 +188,14 @@ data units.")
"doc/build/man/khal.1"
(string-append (assoc-ref outputs "out") "/share/man/man1"))
#t))
- (add-before 'check 'fix-tests
- (lambda _
- ;; Reported upstream: <https://github.com/pimutils/khal/issues/947>.
- (substitute* "tests/cli_test.py"
- (("Invalid value for \"\\[ICS\\]\"") "Invalid value for \\'[ICS]\\'"))
- #t))
(replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The tests require us to choose a timezone.
- (setenv "TZ"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo/Zulu"))
- (invoke "py.test" "tests"))))))
+ (lambda* (#:key inputs tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ ;; The tests require us to choose a timezone.
+ (setenv "TZ" "UTC")
+ ;; The disabled test expects /dev/tty.
+ (invoke "pytest" "tests" "-k" "not test_import_from_stdin"))))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
@@ -229,6 +214,11 @@ data units.")
("python-icalendar" ,python-icalendar)
("python-tzlocal" ,python-tzlocal)
("python-urwid" ,python-urwid)
+ ("python-pytz" ,python-pytz)
+ ("python-setproctitle" ,python-setproctitle)
+ ("python-atomicwrites" ,python-atomicwrites)
+ ("python-click" ,python-click)
+ ("python-click-log" ,python-click-log)
("python-pyxdg" ,python-pyxdg)))
(synopsis "Console calendar program")
(description "Khal is a standards based console calendar program,