summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-21 23:09:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-21 23:09:57 +0300
commit17e88168c3abb87ede709b18e376cdd4fe643b27 (patch)
tree52621c4c42118da1f2d7e2ae665619ce76570f50 /gnu/packages/calendar.scm
parentde3c03a47160dec355d9b19ad5ca210d90c15fd7 (diff)
downloadguix-patches-17e88168c3abb87ede709b18e376cdd4fe643b27.tar
guix-patches-17e88168c3abb87ede709b18e376cdd4fe643b27.tar.gz
gnu: libical: Use local docbook-xml package.
* gnu/packages/calendar.scm (libical)[native-inputs]: Add docbook-xml-4.3. [arguments]: Add phase to substitute docbook location.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 78f0c9848f..b7b1ab0b28 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages dav)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -131,6 +132,13 @@ the <tz.h> library for handling time zones and leap seconds.")
"-DICAL_GLIB_VAPI=true")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "doc/reference/libical-glib/libical-glib-docs.sgml.in"
+ (("http://www.oasis-open.org/docbook/xml/4.3/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/")))
+ #t))
(add-before 'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
;; TODO: libical 3.1.0 supports using TZDIR instead of a hard-coded
@@ -145,7 +153,8 @@ the <tz.h> library for handling time zones and leap seconds.")
(("\\\"/usr/share/lib/zoneinfo\\\"") "")))
#t)))))
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
+ `(("docbook-xml" ,docbook-xml-4.3)
+ ("gobject-introspection" ,gobject-introspection)
("gtk-doc" ,gtk-doc)
("perl" ,perl)
("pkg-config" ,pkg-config)