summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-08-08 20:08:39 +0100
committerMathieu Othacehe <othacehe@gnu.org>2022-08-11 10:22:57 +0200
commitfba67be225e2c8d2f4fb6455042c84b18ad59b89 (patch)
tree92c6f5b9162e7b6c60a23842838a58c5e1ff1d63 /gnu/packages/c.scm
parentdfda2cc5f6a57a0b89b98f389a2f28bf1e94eaa4 (diff)
downloadguix-patches-fba67be225e2c8d2f4fb6455042c84b18ad59b89.tar
guix-patches-fba67be225e2c8d2f4fb6455042c84b18ad59b89.tar.gz
gnu: pcc: Respect --without-tests.
* gnu/packages/c.scm (pcc)[arguments]<#:phases>{check}: Respect the `tests?` argument. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 113a331070..39f048e993 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -197,8 +197,9 @@ standard.")
(substitute* (list "cc/ccom/scan.l" "cc/cxxcom/scan.l")
(("lineno, ") ""))))
(replace 'check
- (lambda _
- (invoke "make" "-C" "cc/cpp" "test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "-C" "cc/cpp" "test")))))))
(native-inputs (list bison flex))
(synopsis "Portable C compiler")
(description