summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-11-12 19:05:17 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-26 00:16:36 +0100
commitf170603e026deac200ebde05401d9a81d87884b3 (patch)
treee176c9d89bb63462628cad2d87358fad86af4711 /gnu/packages/c.scm
parent3a4d5ddd322c7daf0a8c83ca2c87c3fc38b19f0b (diff)
downloadguix-patches-f170603e026deac200ebde05401d9a81d87884b3.tar
guix-patches-f170603e026deac200ebde05401d9a81d87884b3.tar.gz
gnu: Add libhx.
* gnu/packages/c.scm (libhx): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 6e1d304dfc..6428e86e70 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -281,3 +282,25 @@ Its three main components are:
"The purpose of libfixposix is to offer replacements for parts of POSIX
whose behaviour is inconsistent across *NIX flavours.")
(license license:boost1.0)))
+
+(define-public libhx
+ (package
+ (name "libhx")
+ (version "3.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libhx/libHX/"
+ "libHX-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i8v2464p830c15myknvvs6bhxaf663lrqgga95l94ygfynkw6x5"))))
+ (build-system gnu-build-system)
+ (home-page "http://libhx.sourceforge.net")
+ (synopsis "C library with common data structures and functions")
+ (description
+ "This is a C library (with some C++ bindings available) that provides data
+structures and functions commonly needed, such as maps, deques, linked lists,
+string formatting and autoresizing, option and config file parsing, type
+checking casts and more.")
+ (license license:lgpl2.1+)))