summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 13:58:33 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:58 +0200
commitd9b8cfd6c649fb246f7fdf2dc283c27c4afae100 (patch)
tree82e32d66e69e3216cd99ef85bc4b1a638e8a2a34 /gnu/packages/c.scm
parentd061193e786b0a8d5df9e4adf713964eb2d2c965 (diff)
downloadguix-patches-d9b8cfd6c649fb246f7fdf2dc283c27c4afae100.tar
guix-patches-d9b8cfd6c649fb246f7fdf2dc283c27c4afae100.tar.gz
gnu: Add aws-c-http.
* gnu/packages/c.scm (aws-c-http): New variable. * gnu/packages/patches/aws-c-http-cmake-prefix.patch, gnu/packages/patches/aws-c-http-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 2a2b140e1b..4490d391e6 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -712,3 +712,34 @@ cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
(description "The @acronym{PCL, Portable Coroutine Library} implements the
low level functionality for coroutines.")
(license license:gpl2+)))
+
+(define-public aws-c-http
+ (package
+ (name "aws-c-http")
+ (version "0.6.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18xlgz68zizkcp784bs6hkyx0gvp0f1p076i46z653bcd3qa87b4"))
+ (patches
+ (search-patches
+ "aws-c-http-cmake-prefix.patch"
+ "aws-c-http-disable-networking-tests.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-compression" ,aws-c-compression)
+ ("aws-c-io" ,aws-c-io)))
+ (synopsis "Amazon Web Services HTTP library")
+ (description
+ "This library provides a C99 implementation of the HTTP/1.1 and HTTP/2
+specifications.")
+ (home-page "https://github.com/awslabs/aws-c-http")
+ (license license:asl2.0)))