summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-10-12 16:43:40 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-13 14:15:14 +0200
commitc1ea1a94c33035a5aec413617d502884647af628 (patch)
tree20e8fbfa3465a2318feafdee7bad3acdb1046d69 /gnu/packages/c.scm
parent038dec75e75b6ca4abbca486b723a39664db4036 (diff)
downloadguix-patches-c1ea1a94c33035a5aec413617d502884647af628.tar
guix-patches-c1ea1a94c33035a5aec413617d502884647af628.tar.gz
gnu: libhx: Fix runtime bug.
There is a bug in libhx causing pam-mount to crash when trying to mount user directories at login. Upstream has a patch to fix this issue. * gnu/packages/patches/libhx-fix-double-free-bug.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/c.scm (libhx)[source]: Use it.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 7fdac40a97..9f30295067 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
@@ -259,7 +259,8 @@ whose behaviour is inconsistent across *NIX flavours.")
(uri (string-append "https://inai.de/files/libhx/"
"libHX-" version ".tar.xz"))
(sha256
- (base32 "1f4rmarym1j368cbxhqzyvdn5dk4bh8951s19ffqwql16anqsgfr"))))
+ (base32 "1f4rmarym1j368cbxhqzyvdn5dk4bh8951s19ffqwql16anqsgfr"))
+ (patches (search-patches "libhx-fix-double-free-bug.patch"))))
(build-system gnu-build-system)
(home-page "https://inai.de/projects/libhx/")
(synopsis "C library with common data structures and functions")