summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-11-21 14:52:59 +0100
committerLudovic Courtès <ludo@gnu.org>2018-11-21 17:38:00 +0100
commitbf6859e45ad33aa631fc231b23df2d56aff97360 (patch)
tree54602dbcd597ab8e3d9c6fef8ab94e63400b1010 /gnu/packages/c.scm
parente555bbfc48ebb4ca019d3648324b1900a891cda1 (diff)
downloadguix-patches-bf6859e45ad33aa631fc231b23df2d56aff97360.tar
guix-patches-bf6859e45ad33aa631fc231b23df2d56aff97360.tar.gz
gnu: libbytesize: Make .mo file builds reproducible.
* gnu/packages/c.scm (libbytesize)[sources](modules, snippet): New fields. [arguments]: Add #:configure-flags and #:phases.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm43
1 files changed, 38 insertions, 5 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index d89b6ea00d..c5141451f0 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -185,8 +185,45 @@ compiler while still keeping it small, simple, fast and understandable.")
"download/" version "/libbytesize-" version ".tar.gz"))
(sha256
(base32
- "0bbqzln1nhjxl71aydq9k4jg3hvki9lqsb4w10s1i27jgibxqkdv"))))
+ "0bbqzln1nhjxl71aydq9k4jg3hvki9lqsb4w10s1i27jgibxqkdv"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This Makefile hard-codes MSGMERGE et al. instead of
+ ;; honoring what 'configure' detected. Fix that.
+ (substitute* "po/Makefile.in"
+ (("^MSGMERGE = msgmerge")
+ "MSGMERGE = @MSGMERGE@\n"))
+ #t))))
(build-system gnu-build-system)
+ (arguments
+ ;; When running "make", the POT files are built with the build time as
+ ;; their "POT-Creation-Date". Later on, "make" notices that .pot
+ ;; files were updated and goes on to run "msgmerge"; as a result, the
+ ;; non-deterministic POT-Creation-Date finds its way into .po files,
+ ;; and then in .gmo files. To avoid that, simply make sure 'msgmerge'
+ ;; never runs. See <https://bugs.debian.org/792687>.
+ '(#:configure-flags '("ac_cv_path_MSGMERGE=true")
+
+ #:phases (modify-phases %standard-phases
+ (add-after 'configure 'create-merged-po-files
+ (lambda _
+ ;; Create "merged PO" (.mpo) files so that 'msgmerge'
+ ;; doesn't need to run.
+ (for-each (lambda (po-file)
+ (let ((merged-po
+ (string-append (dirname po-file) "/"
+ (basename po-file
+ ".po")
+ ".mpo")))
+ (copy-file po-file merged-po)))
+ (find-files "po" "\\.po$"))
+ #t)))
+
+ ;; One test fails because busctl (systemd only?) and python2-pocketlint
+ ;; are missing. Should we fix it, we would need the "python-2" ,
+ ;; "python2-polib" and "python2-six" native-inputs.
+ #:tests? #f))
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)
@@ -194,10 +231,6 @@ compiler while still keeping it small, simple, fast and understandable.")
(inputs
`(("mpfr" ,mpfr)
("pcre" ,pcre)))
- ;; One test fails because busctl (systemd only?) and python2-pocketlint
- ;; are missing. Should we fix it, we would need the "python-2" ,
- ;; "python2-polib" and "python2-six" native-inputs.
- (arguments `(#:tests? #f))
(home-page "https://github.com/storaged-project/libbytesize")
(synopsis "Tiny C library for working with arbitrary big sizes in bytes")
(description