summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-01-19 12:43:48 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-12 23:58:54 +0100
commit9d541e97e99793d0c75f01bc52de61473632e0ec (patch)
tree3ab64c939ab11cdba0d22d17bd154f78007ecd48 /gnu/packages/c.scm
parentbb5d84a0489a629d30bc2e978807caf20f46e329 (diff)
downloadguix-patches-9d541e97e99793d0c75f01bc52de61473632e0ec.tar
guix-patches-9d541e97e99793d0c75f01bc52de61473632e0ec.tar.gz
gnu: aws-c-common: Update to 0.5.2.
* gnu/packages/c.scm (aws-c-common): Update to 0.5.2. [arguments]: Build as shared library. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 7d8d41d266..75fa6460be 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -545,7 +545,7 @@ portability.")
(define-public aws-c-common
(package
(name "aws-c-common")
- (version "0.4.63")
+ (version "0.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -554,8 +554,11 @@ portability.")
(file-name (git-file-name name version))
(sha256
(base32
- "16bc6fn1gq3nqcrzgpi2kjphq7xkkr73aljakrg89ysm6hyzyim9"))))
+ "0rd2qzaa9mmn5f6f2bl1wgv54f17pqx3vwyy9f8ylh59qfnilpmg"))))
(build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
(synopsis "Amazon Web Services core C library")
(description
"This library provides common C99 primitives, configuration, data