summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-18 18:35:11 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:52 +0100
commit963ebbc62c1b2eee49f5b00ecd5fb8e11dbbdced (patch)
treec3e1793a22e35444ae915e45577ec05514fbddb0 /gnu/packages/c.scm
parentc769b8c2b5bf97cf9aaaa9b151012763355b1f66 (diff)
downloadguix-patches-963ebbc62c1b2eee49f5b00ecd5fb8e11dbbdced.tar
guix-patches-963ebbc62c1b2eee49f5b00ecd5fb8e11dbbdced.tar.gz
gnu: aws-c-event-stream: Replace patch.
* gnu/packages/c.scm (aws-c-event-stream): Replace patch. [arguments]: Fix CMAKE_PREFIX_PATH. [source]: Remove patch. * gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch: Delete file. * gnu/local.mk: Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3b10579ee7..34c87c2d4b 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -605,6 +605,7 @@ with fallback to efficient C99 software implementations.")
(define-public aws-c-event-stream
(package
(name "aws-c-event-stream")
+ ; Update only when updating aws-crt-cpp.
(version "0.2.7")
(source (origin
(method git-fetch)
@@ -614,12 +615,13 @@ with fallback to efficient C99 software implementations.")
(file-name (git-file-name name version))
(sha256
(base32
- "0xwwr7gdgfrphk6j7vk12rgimfim6m4qnj6hg8hgg16cplhvsfzh"))
- (patches (search-patches "aws-c-event-stream-cmake-prefix.patch"))))
+ "0xwwr7gdgfrphk6j7vk12rgimfim6m4qnj6hg8hgg16cplhvsfzh"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
+ (list "-DBUILD_SHARED_LIBS=ON"
+ (string-append "-DCMAKE_PREFIX_PATH="
+ (assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
`(("aws-c-common" ,aws-c-common)
("aws-c-io" ,aws-c-io)