summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-01-19 12:51:36 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-12 23:58:54 +0100
commit748e2ec07a4f484dd4416b4cac5c28b1b13c47ee (patch)
tree3c4f204faf3c0b07a3c4399ba4ee085bbdd99c90 /gnu/packages/c.scm
parentcc95d03ec7aa2d4de2f880fdb0c9ccbf3343e041 (diff)
downloadguix-patches-748e2ec07a4f484dd4416b4cac5c28b1b13c47ee.tar
guix-patches-748e2ec07a4f484dd4416b4cac5c28b1b13c47ee.tar.gz
gnu: Add aws-c-cal.
* gnu/packages/c.scm (aws-c-cal): New variable. * gnu/packages/patches/aws-c-cal-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 1e338bd7bd..c83e6f36e3 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -52,6 +52,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages gettext)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages xml))
(define-public tcc
@@ -619,3 +620,32 @@ event stream encoding, a binary format for bidirectional client-server
communication.")
(home-page "https://github.com/awslabs/aws-c-event-stream")
(license license:asl2.0)))
+
+(define-public aws-c-cal
+ (package
+ (name "aws-c-cal")
+ (version "0.4.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04acra1mnzw9q7jycs5966akfbgnx96hkrq90nq0dhw8pvarlyv6"))
+ (patches (search-patches "aws-c-cal-cmake-prefix.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-common" ,aws-c-common)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("openssl:static" ,openssl "static")))
+ (synopsis "Amazon Web Services Crypto Abstraction Layer")
+ (description "This library provides a C99 wrapper for hash, HMAC, and ECC
+cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
+ (home-page "https://github.com/awslabs/aws-c-cal")
+ (license license:asl2.0)))