summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 06:35:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 13:19:33 +0100
commit5d0bd1fbbf00c3f8a06fc64b29f801780f4d46b2 (patch)
tree6fd8c8c4707102516d2875905128de9b808d63a0 /gnu/packages/c.scm
parentb7cbcee552c5bd4e8398fc70a3a45eaa002b2770 (diff)
downloadguix-patches-5d0bd1fbbf00c3f8a06fc64b29f801780f4d46b2.tar
guix-patches-5d0bd1fbbf00c3f8a06fc64b29f801780f4d46b2.tar.gz
gnu: tcc: Update to 0.9.27.
* gnu/packages/c.scm (tcc): Update to 0.9.27. [license]: Add a comment about attempted Expat re-licencing.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index d15d35e68d..b4e17cb53a 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,14 +35,14 @@
(define-public tcc
(package
(name "tcc") ;aka. "tinycc"
- (version "0.9.26")
+ (version "0.9.27")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/tinycc/tcc-"
version ".tar.bz2"))
(sha256
(base32
- "0wbdbdq6090ayw8bxnbikiv989kykff3m5rzbia05hrnwhd707jj"))))
+ "177bdhwzrnqgyrdv1dwvpd04fcxj68s5pm1dzwny6359ziway8yy"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)
("texinfo" ,texinfo)))
@@ -71,6 +72,8 @@
written in C. It supports ANSI C with GNU and extensions and most of the C99
standard.")
(home-page "http://www.tinycc.org/")
+ ;; An attempt to re-licence tcc under the Expat licence is underway but not
+ ;; (if ever) complete. See the RELICENSING file for more information.
(license license:lgpl2.1+)))
(define-public tcc-wrapper