summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-25 03:47:42 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-05 23:56:58 +0200
commit312879fddcf0713c0f1dafcc6faa089edbbb6e04 (patch)
tree6d6bb17af0a5f3b5d657e548217814a38b1246fa /gnu/packages/c.scm
parent0f024554e63a49e20c2a7a67e928073c266bf5c5 (diff)
downloadguix-patches-312879fddcf0713c0f1dafcc6faa089edbbb6e04.tar
guix-patches-312879fddcf0713c0f1dafcc6faa089edbbb6e04.tar.gz
gnu: Add byacc.
* gnu/packages/c.scm (byacc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index fff7b166f6..da034d5fd9 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -581,6 +582,28 @@ portability.")
(license (list license:bsd-2 ;all files except...
license:bsd-3)))) ;...the unidef.1 manual page
+(define-public byacc
+ (package
+ (name "byacc")
+ (version "20210808")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://invisible-mirror.net/archives/byacc/byacc-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "10rsgnygn11358jr2dn6bbjj7sj9d9hqf6piqxil4nfhx6dm4n7i"))))
+ (build-system gnu-build-system)
+ (home-page "https://invisible-island.net/byacc/byacc.html")
+ (synopsis "Berkeley Yacc LALR parser generator")
+ (description
+ "Berkeley Yacc is an LALR(1) parser generator. Yacc reads the grammar
+specification from a file and generates an LALR(1) parser for it. The parsers
+consist of a set of LALR(1) parsing tables and a driver routine written in the
+C programming language.")
+ (license license:public-domain)))
+
(define-public aws-c-common
(package
(name "aws-c-common")