summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-10-15 10:04:18 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-15 11:16:58 +0200
commit2f0986b0f7cbf4dec5a3e575c67a508cf71c6dd5 (patch)
tree405da711d1641c008ec8d399680de2144a8df16f /gnu/packages/c.scm
parent87d04cdd877492ce42b371d0c4822b2007eddc11 (diff)
downloadguix-patches-2f0986b0f7cbf4dec5a3e575c67a508cf71c6dd5.tar
guix-patches-2f0986b0f7cbf4dec5a3e575c67a508cf71c6dd5.tar.gz
gnu: libhx: Update to 4.1.
* gnu/packages/patches/libhx-fix-double-free-bug.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/c.scm (libhx): Update to 4.1. [source]: Remove patch.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 6b6eddaa09..e00e9920f3 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -252,15 +252,14 @@ whose behaviour is inconsistent across *NIX flavours.")
(define-public libhx
(package
(name "libhx")
- (version "4.0.1")
+ (version "4.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://inai.de/files/libhx/"
"libHX-" version ".tar.xz"))
(sha256
- (base32 "1f4rmarym1j368cbxhqzyvdn5dk4bh8951s19ffqwql16anqsgfr"))
- (patches (search-patches "libhx-fix-double-free-bug.patch"))))
+ (base32 "1mifpzxr5kma7gawhv1vbga8j5qi8jgka0axr48v08bdpb83pya2"))))
(build-system gnu-build-system)
(home-page "https://inai.de/projects/libhx/")
(synopsis "C library with common data structures and functions")