summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-31 16:41:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-31 17:47:44 +0200
commit0270b24b65a06547d43e77eebed0e19ad8ab6e15 (patch)
tree2a5bc8be435b0bb7bfca781569af7618afa2660f /gnu/packages/c.scm
parent740a335558a440245a2374fae9ffaa3427aa546c (diff)
downloadguix-patches-0270b24b65a06547d43e77eebed0e19ad8ab6e15.tar
guix-patches-0270b24b65a06547d43e77eebed0e19ad8ab6e15.tar.gz
gnu: tcc: Mark aarch64-linux as supported.
* gnu/packages/c.scm (tcc)[supported-systems]: Remove aarch64.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index c5141451f0..692e9e714d 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,8 +38,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages gettext)
- #:use-module (gnu packages pkg-config)
- #:use-module (srfi srfi-1))
+ #:use-module (gnu packages pkg-config))
(define-public tcc
(package
@@ -72,8 +72,7 @@
"/lib"))
#:test-target "test"))
;; Fails to build on MIPS: "Unsupported CPU"
- (supported-systems (fold delete %supported-systems
- '("mips64el-linux" "aarch64-linux")))
+ (supported-systems (delete "mips64el-linux" %supported-systems))
(synopsis "Tiny and fast C compiler")
(description
"TCC, also referred to as \"TinyCC\", is a small and fast C compiler